Upgrading a Portal and Data Collectors > Running the Upgrade Utility
  
Version 10.1.01
Running the Upgrade Utility
The following instructions assume that the Portal and Database components reside on the same server.
1. Verify your current StorageConsole version. You must be currently running StorageConsole version 9.2.01 or greater.
2. Verify that the libXtst.so.6 libraries are installed.
3. Ensure that all APTARE StorageConsole application services are up and running. Next, as user root run the following command and respond to the prompts accordingly.
sh /opt/aptare/upgrade/upgrade.sh
If there are errors during the upgrade, the following banner is displayed:
##############################################################
# WARNING WARNING WARNING WARNING WARNING #
# Possible problems were encountered during the upgrade. #
# Please check the log file /opt/aptare/upgrade/logs/upgrade.log #
# for errors and contact Customer Support if necessary. #
##############################################################
4. If the upgrade process encountered any errors, save a copy of the log file for any correspondence with the APTARE Global Support Services. You can find the upgrade log file in the following location:
/opt/aptare/upgrade/logs/upgrade.log
Note: If you have installed any patches on your present APTARE StorageConsole version, please check the APTARE StorageConsole Release Notes to verify that they are included in this release. If you are uncertain, please check with the APTARE Global Support Services. In most cases, previously installed patches are included in the current release.